$re = '/a-color-price\'.*?\$(.*?)</';
$str = '<span class=\'a-color-price\'>$8.36</span></div> $7.99 per month\\" \\"cartContent\\":{\\"html\\":\\"<div id=\'nav-cart-flyout\' </sdd>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);