// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"a-color-price'.*?\$(.*?)<").unwrap();
let string = "<span class='a-color-price'>$8.36</span></div> $7.99 per month\\\" \\\"cartContent\\\":{\\\"html\\\":\\\"<div id='nav-cart-flyout' </sdd>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}