package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<identifiant>(?:[a-z0-9-_]+\.)*[a-z0-9]+)@(?<domaine>(?:[a-z0-9-_]+\.)*)(?<extension>[a-z]{2,6})`)
var str = `test.test@test.test
toto@regex101.com
identifier@domain.subdomain.com
toto@do-main.gouv`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}