import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<identifiant>(?:[a-z0-9-_]+\\.)*[a-z0-9]+)@(?<domaine>(?:[a-z0-9-_]+\\.)*)(?<extension>[a-z]{2,6})";
final String string = "test.test@test.test\n"
+ "toto@regex101.com\n"
+ "identifier@domain.subdomain.com\n"
+ "toto@do-main.gouv";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}