$re = '/\[text_box title="(.*?)" align="(.*?)"/';
$str = '[text_box title="Michael Jordan" align="left"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);