re = /\[text_box title="(.*?)" align="(.*?)"/
str = '[text_box title="Michael Jordan" align="left"]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end