using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*?href=""\K[^""]+";
string input = @"<h1><a href=""http://www.website.com/article/slug-that-has-undetermined-amount-of-hyphens/12345"">Whatever</a></h1>
<p>Here is a url as plain text: http://www.website.com/article/sluggy-slug</p>
<div>Here is a qualifying link: <a href=""http://www.website.com/article/slugger-sluggington-jr/666"">Whatever</a></div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}