use strict;
my $str = 'AH00558: httpd: Could not reliably determine the server\'s fully qualified domain name, using ::1. Set the \'ServerName\' directive globally to suppress this message
AH00557: httpd: apr_sockaddr_info_get() failed for Samirs-MacBook-Pro.local
AH00558: httpd: Could not reliably determine the server\'s fully qualified domain name, using 127.0.0.1. Set the \'ServerName\' directive globally to suppress this message
';
my $regex = qr/(.*): (.*): (.*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}