$re = '/(.*): (.*): (.*)/';
$str = 'AH00558: httpd: Could not reliably determine the server\'s fully qualified domain name, using ::1. Set the \'ServerName\' directive globally to suppress this message
AH00557: httpd: apr_sockaddr_info_get() failed for Samirs-MacBook-Pro.local
AH00558: httpd: Could not reliably determine the server\'s fully qualified domain name, using 127.0.0.1. Set the \'ServerName\' directive globally to suppress this message
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);