$re = '/^(?:.(?=.*\n(\1?.)))*?X.*\n\1?(.)/m';
$str = 'X.........
..........
...X......
..........
..X.......
..........
.......X..
..........
.........X
..........';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);