package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-zA-Z]+?\s*?\(.*?\)`)
var str = `int addFive() {
}
addFive()
int addFive()
{
}
int value = addFive ()
addFive(int number)
void sum ( string hello )`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}