re = /[a-zA-Z]+?\s*?\(.*?\)/
str = 'int addFive() {
}
addFive()
int addFive()
{
}
int value = addFive ()
addFive(int number)
void sum ( string hello )'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end