import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"pack_id\": \"(.*)\"";
final String string = "I/okhttp.OkHttpClient: {\n"
+ " \"route_state\": \"give_packs\",\n"
+ " \"shelves\": [\n"
+ " {\n"
+ " \"pack_id\": \"100142009300S2T1599432189\",\n"
+ " \"shelf\": \"13\",\n"
+ " \"total_goods\": 2,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"100143022336S5T1599502063\",\n"
+ " \"shelf\": \"21\",\n"
+ " \"total_goods\": 5,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"100143367911S2T1599558724\",\n"
+ " \"shelf\": \"6\",\n"
+ " \"total_goods\": 2,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"100143699532S5T1599568344\",\n"
+ " \"shelf\": \"30\",\n"
+ " \"total_goods\": 5,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"50127475503S1T1599567324\",\n"
+ " \"shelf\": \"10\",\n"
+ " \"total_goods\": 1,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"100143773834S4T1599570622\",\n"
+ " \"shelf\": \"36\",\n"
+ " \"total_goods\": 4,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"100143789121S1T1599571959\",\n"
+ " \"shelf\": \"4\",\n"
+ " \"total_goods\": 1,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"100143772313S1T1599587841\",\n"
+ " \"shelf\": \"29\",\n"
+ " \"total_goods\": 1,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"50127216356S2T1599555765\",\n"
+ " \"shelf\": \"16\",\n"
+ " \"total_goods\": 2,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"100143911917S9T1599578036\",\n"
+ " \"shelf\": \"28\",\n"
+ " \"total_goods\": 9,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"100144040317S3T1599592353\",\n"
+ " \"shelf\": \"45\",\n"
+ " \"total_goods\": 3,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"50122511688S10T1599216787\",\n"
+ " \"shelf\": \"14\",\n"
+ " \"total_goods\": 10,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"100143883877S3T1599580528\",\n"
+ " \"shelf\": \"18\",\n"
+ " \"total_goods\": 3,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"50125998587S5T1599460888\",\n"
+ " \"shelf\": \"35\",\n"
+ " \"total_goods\": 5,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"100143065694S7T1599505793\",\n"
+ " \"shelf\": \"19\",\n"
+ " \"total_goods\": 7,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"50126023780S18T1599462088\",\n"
+ " \"shelf\": \"23\",\n"
+ " \"total_goods\": 18,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"100143257387S1T1599516006\",\n"
+ " \"shelf\": \"3\",\n"
+ " \"total_goods\": 1,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"100143204003S8T1599513922\",\n"
+ " \"shelf\": \"42\",\n"
+ " \"total_goods\": 8,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"100143474921S10T1599546590\",\n"
+ " \"shelf\": \"33\",\n"
+ " \"total_goods\": 10,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"50126884830S5T1599522235\",\n"
+ " \"shelf\": \"22\",\n"
+ " \"total_goods\": 5,\n"
+ " \"pack_state\": \"new\"\n"
+ " },\n"
+ " {\n"
+ " \"pack_id\": \"100142045579S1T1599431118\",\n"
+ " \"shelf\": \"12\",\n"
+ " \"total_goods\": 1,\n"
+ " \"pack_state\": \"new\"\n"
+ " }\n"
+ " ]\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}