$re = '/\bA0000.*\s(\d[\d,]*)/m';
$str = '94039030900 Teile aus Holz, für Möbel, anderweit weder 415,17 EUR ZOLLWERT A0000 2,70000 0,00 11,21
genannt noch inbegriffen. Hier: Schublade 426,38 EUR EUST-WERT B0000 19,00000 0,00 81,01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);