import Foundation
let pattern = #"\bA0000.*\s(\d[\d,]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
94039030900 Teile aus Holz, für Möbel, anderweit weder 415,17 EUR ZOLLWERT A0000 2,70000 0,00 11,21
genannt noch inbegriffen. Hier: Schublade 426,38 EUR EUST-WERT B0000 19,00000 0,00 81,01
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)