package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(error|warn)\]\s+(.+):(\d+):(?:\d+:)\s+(.+)$`)
var str = `[error] C:\Me\MyPath\myFile.scala:18:22: not found: value getaa
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}