$re = '/\[(error|warn)\]\s+(.+):(\d+):(?:\d+:)\s+(.+)$/';
$str = '[error] C:\\Me\\MyPath\\myFile.scala:18:22: not found: value getaa
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);