import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^.+\\n)*abc (\\d+)|^(x)(?==)";
final String string = "x=0\n"
+ "abc 20 \n"
+ "def 76 \n"
+ "ghi 11\n\n"
+ "x=1\n"
+ "def 45\n"
+ "ghi 32\n\n"
+ "x=2\n"
+ "jkl 56\n"
+ "mno 76\n"
+ "abc 134\n\n"
+ ".\n"
+ ".\n"
+ ".\n\n"
+ "x=393\n"
+ "xyz 21\n"
+ "abc 9\n\n"
+ "x=394\n"
+ "ghi\n"
+ "def\n"
+ "xyz";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}