import re
regex = re.compile(r"(?:^.+\n)*abc (\d+)|^(x)(?==)", flags=re.MULTILINE)
test_str = ("x=0\n"
"abc 20 \n"
"def 76 \n"
"ghi 11\n\n"
"x=1\n"
"def 45\n"
"ghi 32\n\n"
"x=2\n"
"jkl 56\n"
"mno 76\n"
"abc 134\n\n"
".\n"
".\n"
".\n\n"
"x=393\n"
"xyz 21\n"
"abc 9\n\n"
"x=394\n"
"ghi\n"
"def\n"
"xyz")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")