package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/export\/var\/path\/(.*?[^\.]+)`)
var str = `/export/var/path/host1.log
/export/var/path/host-02.ac.lp.our.domain.log
/export/var/path/host3.ac.lp.our.domain.log`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}