import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/export\\/var\\/path\\/(.*?[^\\.]+)";
final String string = "/export/var/path/host1.log\n"
+ "/export/var/path/host-02.ac.lp.our.domain.log\n"
+ "/export/var/path/host3.ac.lp.our.domain.log";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}