package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-(\d+:)`)
var str = `Video 2-1: Title Goes Here`
var substitution = "-0\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}