use strict;
my $str = 'Video 2-1: Title Goes Here';
my $regex = qr/-(\d+:)/mp;
my $subst = '-0\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";