const regex = /[-+]?(?<!\d\.)\b[0-9]+\.[0-9]+(?:[eE][-+]?[0-9]+)?\b(?!\.\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[-+]?(?<!\\d\\.)\\b[0-9]+\\.[0-9]+(?:[eE][-+]?[0-9]+)?\\b(?!\\.\\d)', 'g')
const str = `-1.34e+32 +1.34e-32 .34e+32 .34 .3 34 .3e 123.456.789 Seq1..2.3.4.5 -.56 +.78
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}