re = /[-+]?(?<!\d\.)\b[0-9]+\.[0-9]+(?:[eE][-+]?[0-9]+)?\b(?!\.\d)/
str = '-1.34e+32 +1.34e-32 .34e+32 .34 .3 34 .3e 123.456.789 Seq1..2.3.4.5 -.56 +.78
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end