use strict;
my $str = '-1.34e+32 +1.34e-32 .34e+32 .34 .3 34 .3e 123.456.789 Seq1..2.3.4.5 -.56 +.78
12 123 456.23 34,345,767.678
';
my $regex = qr/[-+]?(?<!\d\.)\b[0-9]+(?:[,\s][0-9]+)*\.[0-9]+(?:[eE][-+]?[0-9]+)?\b(?!\.\d)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}