import Foundation
let pattern = #"[-+]?(?<!\d\.)\b[0-9]+(?:[,\s][0-9]+)*\.[0-9]+(?:[eE][-+]?[0-9]+)?\b(?!\.\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
-1.34e+32 +1.34e-32 .34e+32 .34 .3 34 .3e 123.456.789 Seq1..2.3.4.5 -.56 +.78
12 123 456.23 34,345,767.678
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)