package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\(\d{2}\) (9|)[6789]\d{3}-\d{4}$`)
var str = `(21) 8765-4321`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}