$re = '/^\(\d{2}\) (9|)[6789]\d{3}-\d{4}$/';
$str = '(21) 8765-4321';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);