import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ftpk?:";
final String string = "ftp:ladpmxqgvt\n"
+ "ftpx:xfiwyoloqu\n"
+ "ftpk:yol.qdsrehn\n"
+ "ftpc:krjqdzsuhb\n"
+ "ftpk:yolo.taxukj\n"
+ "ftp:qvxarpkjid\n"
+ "ebutlngqkr\n"
+ "yolx.vhznja";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}