import re
regex = re.compile(r"^ftpk?:", flags=re.MULTILINE)
test_str = ("ftp:ladpmxqgvt\n"
"ftpx:xfiwyoloqu\n"
"ftpk:yol.qdsrehn\n"
"ftpc:krjqdzsuhb\n"
"ftpk:yolo.taxukj\n"
"ftp:qvxarpkjid\n"
"ebutlngqkr\n"
"yolx.vhznja")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")