import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?i)^(?=.*?(?:veterinary|animal[^s]|hospital| care |pets?|clinic)) *(?:[^ \\n\\r:]+? +?){1,5}$)(?:(?![\\s\\S]*?(?:(?i)veterinary|animal|hospital|care |pets?|clinic))[\\s\\S]*?)(\\d{2,}[\\s\\S]+?(?: [A-Z][A-Za-z] (?:\\d+-)?\\d+))";
final String string = " \n"
+ " \n"
+ "Symphony Veterinary Center \n\n"
+ "symphony care veterinary \n"
+ " \n"
+ "170 cort 96th St., \n"
+ "naib, NZ 10025 \n"
+ "212-866-8000 \n"
+ " \n"
+ " We care yours like ours !! \n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}