const regex = /((?i)^(?=.*?(?:veterinary|animal[^s]|hospital| care |pets?|clinic)) *(?:[^ \n\r:]+? +?){1,5}$)(?:(?![\s\S]*?(?:(?i)veterinary|animal|hospital|care |pets?|clinic))[\s\S]*?)(\d{2,}[\s\S]+?(?: [A-Z][A-Za-z] (?:\d+-)?\d+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?i)^(?=.*?(?:veterinary|animal[^s]|hospital| care |pets?|clinic)) *(?:[^ \\n\\r:]+? +?){1,5}$)(?:(?![\\s\\S]*?(?:(?i)veterinary|animal|hospital|care |pets?|clinic))[\\s\\S]*?)(\\d{2,}[\\s\\S]+?(?: [A-Z][A-Za-z] (?:\\d+-)?\\d+))', 'gm')
const str = `
Symphony Veterinary Center
symphony care veterinary
170 cort 96th St.,
naib, NZ 10025
212-866-8000
We care yours like ours !!
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}