const regex = /<a href="[^images/][^../][^#][^http://](.*?)\.html">/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a href="[^images\/][^..\/][^#][^http:\/\/](.*?)\\.html">', 'gm')
const str = `<a href="word-word-word.html">`;
const subst = `<a href="prefix-$1.html">`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);