// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a href="[^images/][^../][^#][^http://](.*?)\.html">"#).unwrap();
let string = "<a href=\"word-word-word.html\">";
let substitution = "<a href=\"prefix-$1.html\">";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}