$re = '/(.*)\.(\w+)$/m';
$str = 'test word document.docx
amazing c. document.docx
1. 2. 3.45 document.docx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);