re = /(.*)\.(\w+)$/m
str = 'test word document.docx
amazing c. document.docx
1. 2. 3.45 document.docx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end