re = /^(?!.*centrifugo).*xxx/m
str = '123 centrifugo 551 xxx
451 abcd xxx 334
yyyy xxx 231'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end