$re = '/\<p\>[^—].+\<\/p\>/m';
$str = '<p>Fără să comenteze, Sam mi-a dat paharul cu vin</p>
<p>– pe care l-am examinat atentă, pentru a fi sigură</p>
<p>că e perfect curat – şi am pornit spre masa</p>
<p>vampirului.</p>
<p>— Vinul dumneavoastră, domnule, i-am spus</p>
<p>protocolar, aşezând paharul pe masă, exact în faţa</p>
<p>lui.</p>
<p>El m-a privit din nou, iar eu n-am scăpat ocazia</p>
<p>de a mă uita fix în ochii lui încântători.</p>
<p>— Să-l beţi cu poftă, i-am zis, mândră.</p>
<p>Moment în care Mack Rattray a strigat în</p>
<p>spatele meu:</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);