$re = '/(?<!\S)[-+]?[0-9]*(?:[.,]?[0-9]+(?:[eE][-+]?[0-9]+)?|(?<=\d)[,.])(?!\S)/m';
$str = 'MATCH:
3.45
5,4
.45
3e4
,54
4
4.
4,
,
.
DON\'T MATCH:
4,5e
2e
.3.
2e,4
,4.
d34
2.45t
2,45.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);