re = /^[.#]?(\w+)(?=(?::\w+)?\s*{)/m
str = '.className {
some data here;
some data here;
}
className {
some data here;
}
#className {
some data here;
}
tagName1 {
some data here;
}
#tagName2 {
}
.tagName3:hover {
}
.tagName4:anything {
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end