import Foundation
let pattern = ##"^[.#]?(\w+)(?=(?::\w+)?\s*{)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
.className {
some data here;
some data here;
}
className {
some data here;
}
#className {
some data here;
}
tagName1 {
some data here;
}
#tagName2 {
}
.tagName3:hover {
}
.tagName4:anything {
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)