using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"mul\((\d{1,3}),(\d{1,3})\)";
string input = @"mul(12,15)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}