package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)'([^'\\]*(?:(?:\\.)[^'\\]*)*)'`)
var str = `It was 'He said \'hello\' to her' not the other way around.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}