package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*d=(\d{4}-\d{2})$`)
var str = `http://localhost:3000/study-group.html?d=2021-06`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}