$re = '/^.*d=(\d{4}-\d{2})$/m';
$str = 'http://localhost:3000/study-group.html?d=2021-06';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);