package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:/MOTIF )?(?<VALUE>.*?)( /BEN .*)?$`)
var str = `/MOTIF blablabla /BEN xxxxx….
foobar
/BEN blabla
/MO blabla`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}