re = /^(?:\/MOTIF )?(?<VALUE>.*?)( \/BEN .*)?$/m
str = '/MOTIF blablabla /BEN xxxxx….
foobar
/BEN blabla
/MO blabla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end