$re = '/(?<![a-zA-Z])(?=([a-zA-Z]+\d+[a-zA-Z]+))/m';
$str = 'a123123aas52342ooo345345ooo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);