import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![^?\\n]*\\?).*good\\s+answer";
final String string = "Here are the strings I want to detect:\n"
+ "--------------------------------------\n"
+ "That a very good answer!\n"
+ "(Other than that, this is a really good answer and I've upvoted it.)\n"
+ "good answer dvdf!\n"
+ "dsds good answer cfds\n"
+ "It is a good answer, but I feel it played into the OP's hands really. You said what they wanted to hear - that they shouldn't freely share the information because it is like a child cheating on their homework. It is contrary to the spirit of this site, and I'm not sure that charging a colleague money to learn something work-based from you won't get the OP into trouble with their employer. Imagine if a doctor asked to confer with a fellow doctor in order to help a patient, and they charged each other for the information they shared. They'd be dismissed.\n\n"
+ "Here are the one I don't want to detect\n"
+ "-----------------------------------------\n"
+ "Thanks for this good answer! (I upvoted it) However, I still don't understand why I shouldn't mention that I believe whatever? What's the problem with that...\n"
+ "cxvd good answer? zedfs\n"
+ "ezdds? good answer dsf dsf\n"
+ "sdsd? dsfdsf? good answer!\n"
+ "Hi, the question is \"How to tell blabla when X is my good friend\", would you mind be a little more detail about how OP should do that when OP still want to be friend with both parties? Also, please take some time to read \"How do I write a good answer\n"
+ "As a side note, here is a link to \"How do I write a good answer?\n"
+ "Hi, this sound like a good answer to me, I just have one question though: Where you in a similar situation before where you successfully used this technic? In here it's better to back-up your answer with personal experience (here is a guide to How to write a good answer if you need it)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}